Issue
When working with multiple environments running different versions of Content Hub, specifically 1.x and 2.x, entities stop exporting and importing.
Resolution
Purge all content from Content Hub and re-export only content from an environment running the version you want to keep.
If you are testing 2.x for future use, the best practice is to use a test environment for Content Hub instead of your live Production environment. Please contact your Account Manager to arrange the details of a test environment.
Cause
Content Hub 1.x and 2.x are not compatible; they map entities differently. When entities from both versions are pushed to the same Content Hub account, it will cause errors with the import and export process, causing entities to stop appearing in Content Hub.
It may present in the php-errors.log as:
Uncaught PHP Exception Exception: "Did not retrieve all requested entities.