Ruby EOL for Version 2.5.0 on Pipelines