Issue
My Acquia Campaign Studio (Mautic) campaign appears to have fewer users than the source segment that it is pulling from
Resolution
First, simply unpublish and then republish the campaign that is facing this issue, this should pull in any contacts that were not initially included. If the campaign is republished and is still presenting the same issue, please file a support ticket.
Cause
Occasionally, very large segments (70k+ contacts) used as the source for campaigns will cause the backend job which adds contacts to these campaigns to time out.