Logo Knowledge
  • Product Documentation
  • Insight
  • Developer Center
  • Training
  • Submit a Request
  • Product Documentation
  • Insight
  • Developer Center
  • Training
  • Submit a Request
  1. Acquia Support Knowledge Base
  2. Troubleshooting
  3. Known Issues

Vendored Drush known issue

    See more
    • Updated
    • February 15, 2019 15:30

    Issue

    Including Drush in an Acquia Cloud application branch may disable some Cloud Drush commands, notably Install distribution which allows you to install a different version of Drupal into the deployed branch.

    Resolution

    The suggested workaround is to remove Drush from the branch in which you wish to install a Drupal distribution. This can be accomplished by modifying an existing branch or creating a new branch without the existing application's code.

    Drush is generally found in one of the following directories:

    • vendor/drush

    • docroot/vendor/drush

    Usually this is done with Composer; if so, Composer should be used to remove Drush as follows:

    $ composer remove drush/drush

    Cause

    The root cause is that Drush detects a version of Drush installed in an Acquia Cloud application's code and switches to run in that context.

    Acquia Drush commands, like Install distribution, are not currently available to “vendored” Drush, disabling some features. Acquia is preparing a solution to this issue.

    Acquia Products

    • Acquia Cloud

    Topics

    • drush

    Drupal Projects

    • drush

    External Links

    • Installing a Drupal distribution
    Avatar
    Stacy Wray
    • February 15, 2019 15:30
    • Updated
    • Facebook
    • Twitter
    • LinkedIn
    • Google+

    Was this article helpful?
    0 out of 1 found this helpful
    Have more questions? Submit a request

    Return to top

    Related articles

    • Introduction to Drush
    • Drupal 8: Twig cache
    • Help my drush aliases don't work with Drush 9!
    • Upgrading to Drupal 8.6.0 should be avoided, use 8.6.1 instead
    • How to access Private Repos using Composer

    Support

    Acquia Support Knowledge Base
    • Submit a Request
    • Contact Support
    • Acquia Support Guide
    • Product Documentation
    • System Status

    About Acquia

    • About Us
    • Leadership
    • Board of directors
    • Newsroom
    • Careers
    • Customers
    • Contact Us
    53 State Street, 10th Floor
    Boston, MA 02109
    United States
    Phone: 888-922-7842
    Map: Google Maps
    View other locations
    • Feeds
    • Legal
    • Security Issue?

    Copyright © 2018 Acquia Inc. All Rights Reserved. Drupal is a registered trademark of Dries Buytaert.